Upload file doesn´t work on Active Forums

Feb 14, 2014 at 10:24 AM
Greetings,

I´m a beginner in DNN and AF so forgive me if it is a silly thing. I have implemented DNN and AF on my company and it was working perfectly, including the attachs in AF. However, suddenly, you cannot upload files on a topic anymore. You can "Choose File" but the "Upload" text doesn´t become a link, preventing users from uploading their files. I read a dozen of forums about the same error but none of the solutions worked for me (update active forums module, change the editor for CKEditor, change the skin for DarkKnight, etc.). If someone could tell me the solution or send me a link of a forum with the correct solution I would really appreciate. My DNN version is 07.01.01 and the AF version is 5.1.4.

Thank you guys
Apr 7, 2014 at 3:48 PM
I'm having this same problem and I haven't found a solution yet.

I'm using DNN version 07.01.01, and AF version 5.0.3.
Apr 7, 2014 at 8:41 PM
The problem for me turned out to be some missing js files.

On the post reply page, we found console errors saying that /DesktopMudules/Journal/scripts/jquery.dnnUserFileUpload.js, jquery.fileupload.js, and jquery.iframe-transport.js were all missing. And for some reason I couldn't find those files in any of our DNN installs. Maybe it's some kind of DNN bug?

But once those files were on the server, everything worked fine.

You can get the files here: https://dotnetnuke.codeplex.com/SourceControl/latest
Look under under Trunk/Content_7.0.6/Community/Modules/Journal/Scripts
Coordinator
Apr 7, 2014 at 9:07 PM
Note that this site is no longer used for support issues.

As noted on the home page here, the project has moved to GitHub:

https://github.com/jbrunken/ActiveForums
Jul 2, 2014 at 5:19 PM
I´ve tried to solve by updating the AF version and know I got the missing error:

POST (mysite)/DesktopModules/ActiveForums/API/ForumService/UploadFile 404 (Not Found)

When I checked the /DesktopModules/ActiveForums/ folder in DNN there is no API folder. I´ve tried other forums (https://activeforums.codeplex.com/workitem/1801) but it didn´t work for me. I´ve tried the jquery.dnnUserFileUpload.js/jquery.fileupload.js and also didn´t work for me.

What should I do?