Converted AF 5 Problems

Dec 29, 2012 at 12:56 AM
Edited Dec 29, 2012 at 12:58 AM

With the help of people here most of the convert problems are solved.

Two problems left.

The Last Posts data in the initial forums page have two problems:

1. Some urls from the Last Posts go the the wrong URL ! (if you edit/save the post it is corrected)

2. In some posts shown in Last Posts, the Topic is Empty and the By: is empty AND the DATE is WRONG (if you edit/save the post it is corrected)

See the screen dump

here

The First in red is an example of wrong link if you press it and the second speaks for itself.

Thanks

Dec 29, 2012 at 1:26 AM
Edited Dec 29, 2012 at 1:54 AM

 

Some problems as i find them: (i have run Skiank's scripts but some are not corrected in the BODY of the post)

Errors from the convertion:

June 4th – November 27th, 2011
· the Last Supper (from San Giorgio Maggiore Basilica)
In Milan, Italy's fashion and financial capital
An interesting photographic exhibition, ‘The Veneto of Ernest Hemingway’,
Dec 29, 2012 at 5:57 AM

You need more replaces for Your alphabet. And a check to last post script. I'll reply you this afternoon from My pc.

Dec 29, 2012 at 8:50 AM
skiank wrote:

You need more replaces for Your alphabet. And a check to last post script. I'll reply you this afternoon from My pc.

 

My alphabet is English. Nothing special.

The script needs to be updated i think :)

Dec 29, 2012 at 3:12 PM

But my addon script is for italian special chars. In tour case I see:


·
'

This code beetweek & and ; rapresent special symbol. You have to integrate the scipt with some REPLACE. The Syntax is:

update activeforums_Content

set Body=cast(replace(cast(body as nvarchar(max)),'–','-') as ntext),
[subject] =cast(replace(cast([subject] as nvarchar(max)),'–','-') as ntext)

 

 

 

This Script replace in the BODY and SUBJECT fileds the string – with the -
For a conversion between &...; and the symbiol look here:
http://www.utexas.edu/learn/html/spchar.html

 

 

Dec 30, 2012 at 12:18 AM
skiank wrote:

But my addon script is for italian special chars. In tour case I see:


·
'

This code beetweek & and ; rapresent special symbol. You have to integrate the scipt with some REPLACE. The Syntax is:

 

update activeforums_Content

 

set Body=cast(replace(cast(body as nvarchar(max)),'–','-') as ntext),
[subject] =cast(replace(cast([subject] as nvarchar(max)),'–','-') as ntext)

 
 

 

 

 

This Script replace in the BODY and SUBJECT fileds the string – with the -
For a conversion between &...; and the symbiol look here:
http://www.utexas.edu/learn/html/spchar.html

 

 

 

Thanks, i'm not talking about your script that needs to be updated, i'm talking about the convertion script that needs it.

For example the apostrophe needs to be taken care of.

Dec 30, 2012 at 9:58 AM

I understood that

Dec 30, 2012 at 1:03 PM

 

When there is one post in a thread, i see no "by:" (author) information in the topics view. Just the date.

Dec 30, 2012 at 1:12 PM

 

Some label is missing, at the right bottom of a post, when edited. The Last Edit date apparently.

Right now it only shows a date that nobody knows what it is.

 

Dec 30, 2012 at 4:41 PM

Is the Last Mod. Date. In template you find: [MODEDITDATE]. You can add some lable before. But you can't suppress the label if there is no Mod Date.

 

Dec 30, 2012 at 4:53 PM
skiank wrote:

Is the Last Mod. Date. In template you find: [MODEDITDATE]. You can add some lable before. But you can't suppress the label if there is no Mod Date.

 

 

Then it is an issue. I will open one.

Dec 30, 2012 at 5:22 PM

 

It seems also that Quoted text is not styled as it should.

 

Dec 30, 2012 at 5:40 PM

Quoted text work properly For me. There is an issue if I edit a quoted post with texteditor. Already open it

Dec 30, 2012 at 6:09 PM

 

Also it seems that using the default skin, the links in a text are the same with the rest. You can't see them, there is no stlyling for them apparently.