Error after installing ActiveForums 5.0

Sep 17, 2012 at 4:08 PM

I downloaded the latest version and installed it here (upgraded from latest version 4): http://test.pokerdiy.com/poker-forums.aspx

I am on DNN 6.2.3 and still have AS 1.9.6 installed. 

The forums are now unusable.

 

AssemblyVersion: 6.2.3

PortalID: 6

PortalName: PokerDIY

UserID: -1

UserName:

ActiveTabID: 378

ActiveTabName: Poker Forums

RawURL: /desktopmodules/activeforums/scripts/afscripts.ashx?v=4.3.8&TabId=378&PortalId=6&ModuleId=2333&language=en-US

AbsoluteURL: /desktopmodules/activeforums/scripts/afscripts.ashx

AbsoluteURLReferrer: http://test.pokerdiy.com/poker-forums.aspx

UserAgent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.89 Safari/537.1

DefaultDataProvider: DotNetNuke.Data.SqlDataProvider, DotNetNuke.SqlDataProvider

ExceptionGUID: 6b40520b-311a-43ea-a4f9-99252594caa2

InnerException: Unhandled Error:

FileName:

FileLineNumber: 0

FileColumnNumber: 0

Method: Active.Modules.Forums.DataCache.MainSettings

StackTrace:

Message: System.Exception: Unhandled Error: ---> System.InvalidCastException: Unable to cast object of type 'DotNetNuke.Modules.ActiveForums.SettingsInfo' to type 'Active.Modules.Forums.SettingsInfo'. at Active.Modules.Forums.DataCache.MainSettings(Int32 MID) at Active.Modules.Forums.Handlers.afscripts.ProcessRequest(HttpContext context) at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) --- End of inner exception stack trace ---

Source:

Server Name: Cloud156

 

 

 

 

 

AssemblyVersion: 6.2.3

PortalID: 6

PortalName: PokerDIY

UserID: -1

UserName:

ActiveTabID: 378

ActiveTabName: Poker Forums

RawURL: /poker-forums.aspx

AbsoluteURL: /Default.aspx

AbsoluteURLReferrer: http://test.pokerdiy.com/Default.aspx?tabid=378&error=An%20unexpected%20error%20has%20occurred&content=0

UserAgent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.89 Safari/537.1

DefaultDataProvider: DotNetNuke.Data.SqlDataProvider, DotNetNuke.SqlDataProvider

ExceptionGUID: 4be84b0b-e69b-4006-bfc8-ec7992d29ed3

InnerException: Parameter count does not match Parameter Value count.

FileName:

FileLineNumber: 0

FileColumnNumber: 0

Method: Microsoft.ApplicationBlocks.Data.SqlHelper.AssignParameterValues

StackTrace:

Message: DotNetNuke.Services.Exceptions.PageLoadException: Parameter count does not match Parameter Value count. ---> System.ArgumentException: Parameter count does not match Parameter Value count. at Microsoft.ApplicationBlocks.Data.SqlHelper.AssignParameterValues(SqlParameter[] commandParameters, Object[] parameterValues) at Microsoft.ApplicationBlocks.Data.SqlHelper.ExecuteReader(String connectionString, String spName, Object[] parameterValues) at Active.Modules.Forums.SqlDataProvider.GetPosts(Int32 PortalId, String Forums, Boolean TopicsOnly, Boolean RandomOrder, Int32 Rows, Int32 UserId, Boolean IgnoreSecurity, Boolean IsSuperUser, String Tags, Int32 FilterByUserId) at Active.Modules.Forums.WhatsNew.Page_Load(Object sender, EventArgs e) at System.Web.UI.Control.OnLoad(EventArgs e) at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) --- End of inner exception stack trace ---

Source:

Server Name: Cloud156