CoreForumsToActiveForums-1.5.sql got error

Jul 22, 2013 at 6:33 PM
We have two modules use DNN core forum. When I run CoreForumsToActiveForums-1.5.sql to migration to Active Forums modules. The 1st module was successfully migrated. But the 2nd module. Got error below:

Violation of PRIMARY KEY constraint 'PK_activeforums_Groups'. Cannot insert duplicate key in object 'dbo.activeforums_Groups'

Any suggestions or tips how to resolve this error. Thanks in advance.
Jul 22, 2013 at 6:36 PM
One of the keys/IDs is aleady in the table, this is a data issue, you will need to figure out what data is duplicated then decide what to do about it. Most likely you will need to find the WHERE clause in the SELECT sql to limit out the group name that is already there.
Developer
Jul 22, 2013 at 6:52 PM
Are you importing into an existing AF database, or a new install?
Jul 22, 2013 at 7:19 PM
Thanks for Doug and Crhistoc's quick respond. I looked into the database. Looks like when run the converted script. All Core Forums data migrated to Active Forum. Perhaps I can look into the permission settings.
Editor
Jul 22, 2013 at 7:23 PM
Have a look at this post. The answers that i posted at the bottom sound an awful lot like what I experienced.

Codeplex Discussions 446816
Jul 22, 2013 at 8:00 PM
@ Christoc, it's a new install.
Jul 23, 2013 at 5:15 PM
Edited Jul 23, 2013 at 5:17 PM
Another issues I got - set Forum Groups permission. I have several Forum Groups, each group has different security roles.
ie:
Forum Group A - Role A
Forum Group B - Role B
Forum Group C - Role C

When I assigned Group A to Role A. Other groups also assigned to Role A. I was not able to assign each group to its own roles. Anyone have this issue?
Editor
Jul 23, 2013 at 5:20 PM
I had to delete my existing groups and create new ones. Then reassign the forums to new groups. I was able to regain partial permission functionality but I'm still tracking down this.

I also have an issue now where features don't stick. I set a group to use default DNN editor. Save. Check. It's ok. Go set another group and save. Come back and the default DNN editor is gone. I can say for sure at this point that its a direct result of the migration from DNN forum. Not sure yet if its the script that caused this or the existing data. My dev is currently working on this exact issue right now.

Editor
Jul 23, 2013 at 5:22 PM
Curious what is the history of your DNN forum? What was the originally installed forum version? Like did you start at 5.0.1 or down in the 4 's?

What version did you upgrade from before AF? Dnn forum 5.0.3?
Jul 23, 2013 at 5:36 PM
DNN forum 5.0.3. - DNN 6.2

Delete the existing groups and re-created is not an option for me. Need to keep the data.
Editor
Jul 23, 2013 at 5:47 PM
Not the forum the forum group.

In my setup, all forums belong to different groups. So I can control many of the same from one place.

So the groups are basically just forum security groups. Deleting the group only does that. Just the group. The forums still exist.

If you create new groups first, then move the forums into those new groups you can delete the existing groups after you move the forums.


Developer
Jul 23, 2013 at 7:46 PM
The script doesn't bring over permissions properly so you have to manually go through and set permissions afterwards
Jul 23, 2013 at 9:32 PM
Edited Jul 23, 2013 at 9:34 PM
Thanks everyone responded. I worked around with it and solved my problems. End up I modified the script a little bit. Converted GROUP individual to AF