5.0.3 Beta Updated

Jan 22, 2013 at 3:34 AM
Edited Jan 22, 2013 at 3:36 AM

I just uploaded a new version of the 5.0.3 beta that includes the CK Editor fix.

There are now two separate versions available for 6.2 and 7.0 so take care to download the proper version.

Active Forums 5.0.3 for DNN 6.2-Not for Production

Active Forums 5.0.3 for DNN 7-Not for Production

Jan 22, 2013 at 6:22 AM

I just tried to install this and installation failed.

Environment: DNN CE 7.x Windows Azure Website (Created via DNN Website Gallery Wizard) using Active Forums 5.0.3 for DNN 7
(Note: This is the first time I have used Windows Azure websites AND the first time I have used DNN or Active Forums)

Here is the excerpt for the install log (everything in-between the '...' was completed successfully)

  • Package Installation Report
  • See below for the results of the package installation
  • Error loading files from temporary folder - see below
  • StartJob Starting Installation
  • Info Starting Installation - Active Forums
  • Info Starting Installation - Module
  • Info Module registered successfully - Active Forums
  • Info Component installed successfully - Module
  • Info Starting Installation - Assembly
  • Info Assembly already registered - bin\DotNetNuke.Modules.ActiveForums.dll
  • Info Creating backup of previous version - bin\DotNetNuke.Modules.ActiveForums.dll
  • Info Created - bin\DotNetNuke.Modules.ActiveForums.dll
  • Info Component installed successfully - Assembly
  • Info Starting Installation - File
  • Info Creating backup of previous version - License.txt
  • Info Created - License.txt
  • Info Creating backup of previous version - ReleaseNotes.txt
  • Info Created - ReleaseNotes.txt
  • Info Component installed successfully - File
  • Info Starting Installation - Script
  • Info Begin Sql execution
  • Info Creating backup of previous version - Uninstall.SqlDataProvider
  • Info Created - Uninstall.SqlDataProvider
  • Info Finished Sql execution
  • Info Component installed successfully - Script
  • Info Starting Installation - ResourceFile
  • Info Expanding Resource file
  • Info Creating backup of previous version - 04.03.00.txt
  • Info Created - 04.03.00.txt
  • ...
  • ...
  • ...
  • Info Creating backup of previous version - themes/_default/templates\_Master.ascx
  • Info Created - themes/_default/templates/_Master.ascx
  • Info Resource Files created
  • Info Component installed successfully - ResourceFile
  • Info Starting Installation - Config
  • Info Creating backup of previous version - web.config
  • Info Config file updated - web.config
  • Info Component installed successfully - Config
  • Info Config file changes committed - web.config
  • Info Installation committed
  • Info Installation successful. - Active Forums
  • Info Starting Installation - Active Forums What's New
  • Info Starting Installation - Module
  • Info Module registered successfully - Active Forums What's New
  • Info Component installed successfully - Module
  • Info Starting Installation - File
  • Info Creating backup of previous version - WhatsNew.ascx
  • Info Created - WhatsNew.ascx
  • Info Creating backup of previous version - WhatsNewOptions.ascx
  • Info Created - WhatsNewOptions.ascx
  • Info Component installed successfully - File
  • Info Starting Installation - ResourceFile
  • Info Expanding Resource file
  • Failure Installation Failed - ResourceFile
  • Info Rolling back component install - Module
  • Failure ExceptionSystem.NullReferenceException: Object reference not set to an instance of an object. at DotNetNuke.Services.Installer.Installers.ModuleInstaller.DeleteModule()
  • Info Component rolled back successfully - Module
  • Info Rolling back component install - File
  • Info Restored backup of previous version - WhatsNew.ascx
  • Info Restored backup of previous version - WhatsNewOptions.ascx
  • Info Component rolled back successfully - File
  • Info Installation Failed - Active Forums What's New
  • Info Deleted temporary install folder
  • EndJob Installation Failed
  • Return
Jan 22, 2013 at 4:06 PM

Hmm,   Looks like the WhatsNewResources.zip file got corrupted somehow.   I'll fix it and upload a new version.

Jan 22, 2013 at 6:48 PM

I've updated the install packages.   Please download a new copy and try the install again.

Thanks

-JB

Jan 22, 2013 at 7:05 PM
This is really nice. If someone would point me in the right direction, (old documentation) updated features, I would gladly work on documentation for install etc. I don't have any experience working on the upgrade script, I haven't dove into it yet, but I would gladly update all of this stuff and put it into a logical document in my spare time; whatever that is.
Jan 22, 2013 at 8:10 PM
Edited Jan 22, 2013 at 8:11 PM

The bulk of the existing documentation is still on the Active Modules site:

http://www.activemodules.com/activeforums/kb/

I'm guessing that the bulk of it is still valid.   It probably just needs some minor updates and then to be added to the project documentation Wiki here.

Jan 23, 2013 at 6:20 AM
jbrunken wrote:

I've updated the install packages.   Please download a new copy and try the install again.

Thanks

-JB

Thanks JB,

EndJob : Installation successful.

Worked a treat...

Cheers

Jan 27, 2013 at 8:36 PM

I just uploaded new 5.0.3 beta's for both 6.2 and 7.0

  • Fixed the basic attachment functionality in 7.0 (Note that there are still a few outstanding issues with attachments, but the core functionality works)
  • Add support back for the [AF:PROFILE:PMLINK] tag in the Profile Info Template.  You can now select your messaging type in the Community section of the forum settings (Core messaging or Ventrian). 
  • Saving forum settings now clears the cache.

I don't think I'm going to make any other changes to this version unless we find a critical bug.   Hopefully we can get 5.0.3 tested and out the door soon for production use.

Jan 27, 2013 at 10:49 PM
Edited Jan 28, 2013 at 12:08 AM

Saving forum settings now clears the cache.

Many Thanks for this, save us lot of time :)

Jan 29, 2013 at 12:37 AM

 

I don't see anyone posting the results from the latest beta(s). Does that mean they work without any problems ?

Some 50 downloads but no post about it.

Jan 29, 2013 at 12:55 AM

There is at least one outstanding issue that has been fixed but needs to be added to the build.   I believe Ben was working on some CSS fixes for the DNN 7 build as well.  I'm not sure if those are complete or not yet.

Jan 29, 2013 at 12:57 AM
jbrunken wrote:

There is at least one outstanding issue that has been fixed but needs to be added to the build.   I believe Ben was working on some CSS fixes for the DNN 7 build as well.  I'm not sure if those are complete or not yet.


My post was not about your efforts, i'm sure you are doing your best. And personally i'm grateful.

I was asking if users installed and used the latest betas. And what are the results. I haven't seen any comments about it.

Jan 29, 2013 at 1:04 AM

I can but I think my issues are related only  to my websites. 

e.g. I don't have access to control panel. The circle keeps rotating and then nothing. 

Topic view throws an error. ( soemthing about active forum control buttons  . must be dotnetnuke instead of Active Forum.) Since I dont have access to the control panel I cannot edit the custom templates. 

Jan 29, 2013 at 12:53 PM

Downloaded... I'm testing...

Jan 30, 2013 at 8:05 PM
Edited Jan 30, 2013 at 8:06 PM

 

DNN 7 - AF 503

I installed to a test system AF 503 for DNN7, a clean install in an empty website. Not a real test but ...

After spending 2-3 hours with it, i found no real problems. Some small display missplacements, nothing to worry about.

Most of my issues are fixed, Ckeditor 202 works well, attachments do work as were designed (very poorly designed, but this is an other talk).

I will spend some more time tomorrow and maybe when the next DNN version is out (703 ?) i will move everything to 7. I have realized that we MUST move to 7. Many things to gain for us and the developpers also (meaning better modules).

For the people that have contributed the last weeks a BIG THANKS.

Feb 9, 2013 at 4:55 AM
How is this going for everybody ?

Is 5.0.3 for DNN 7 fully updated with all the changes ?

Maybe time for a release if no problems are reported (minnor ones have been reported) ....
Feb 9, 2013 at 5:20 AM
Yeah, I agree.

I still need to push up a version that has one minor fix. Other than that I think it's ready to go. It's not up to me though. I need to get the official OK from Will.

-JB
Feb 11, 2013 at 2:15 AM
Edited Feb 11, 2013 at 2:16 AM
jbrunken wrote:
Yeah, I agree.

I still need to push up a version that has one minor fix. Other than that I think it's ready to go. It's not up to me though. I need to get the official OK from Will.

-JB
We are all looking forward to it. DNN 703 was out a few days ago, and looks very nice, a lot of things fixed.

All we need now is a somehow stable AF version for DNN 7. Please let us know how this progress is going. Should we ask the Red Cross to look for Will ?

:)
Feb 13, 2013 at 2:51 AM
I just pushed up new builds that include the journal reply fix. Will also pointed out a problem with how I was building against the DotNetNuke DLL's and I've corrected that as well.

Let's test this for a day or two and if there are no other problems maybe we can turn it into a release.
Feb 13, 2013 at 6:20 AM
Is anyone else experiencing the problem where the Text editor when creating a post is just a large text box, no formatting options?
Feb 13, 2013 at 7:47 AM
christoc wrote:
Is anyone else experiencing the problem where the Text editor when creating a post is just a large text box, no formatting options?
Dnn 7 ? or 6.2 ?

I haven't seen it in DNN 6..2 x.
Feb 13, 2013 at 2:16 PM
Which editor provider are you using? I've seen that some under DNN 7, but I thought it might have been because I was using CKEditor. Maybe there's a bigger problem.
Feb 13, 2013 at 4:25 PM
jbrunken wrote:
Which editor provider are you using? I've seen that some under DNN 7, but I thought it might have been because I was using CKEditor. Maybe there's a bigger problem.
There was indeed a problem with Ckeditor and DNN7, as you say. But is resolved now.

Not sure if Christoc is having the same problem ...
Feb 13, 2013 at 4:29 PM
I am referring to the new post screen, using the standard html provider DNN7, this is my dev site, but I have two production sites that look the same

Image

It is my understanding that the Message box should actually have some formatting options to it
Feb 13, 2013 at 4:38 PM
Chris

Same for me IF i select non-html input in Control Panel/Forums/Details/Features/Html Input.

I think it is normal. You should enable Html Input....
Feb 13, 2013 at 8:24 PM
Thanks, I guess I was expecting something else from the editor.

I'll enable the HTML editor for now, though I know my users will complain about it not being BBcode :D
Feb 13, 2013 at 8:34 PM
I'm 100% in favor of adding better BBCode support.

In fact, I would love to see a mode that just disables the HTML editor and does everything with BBCode, but I believe it would require some refactoring.

I had to really jump through hoops in the Tapatalk module to deal with the transitions back and forth between bbCode and HTML. It's like converting from blu-ray to VHS then back to blu-ray. It kind of works, but a lot tends to get lost in the process.
Feb 13, 2013 at 9:06 PM
Isn't BBCode supported via the Filters which are already in AF? They might need a little work regarding the REGEX patterns, but they should work for most replacements.
Feb 14, 2013 at 2:24 PM
There filters handle a few of the basic bbCode, but it's not near a complete implementation of bbCode. There is some bbCode functionality that is fairly complex and would require some well written regular expression filters. The other issue is that the filters currently appear to be case sensitive which doesn't help the situation at all (this is on my list of things to look at).

There's also the issue of "editing" a post. Right now the filters run at the time the message is saved. If you edit the post, you need to "reverse" the filter process, which only works for a few of the filters.

I think the filters are a great and useful feature, but also think having a true "bbCode" mode with a decent bbCode javascript UI as an option would be a big plus.
Feb 14, 2013 at 2:24 PM
You all do realize that BBcode is legacy and the Facebook generation has no idea what that could be ...
Feb 14, 2013 at 2:26 PM
zaratustra wrote:
You all do realize that BBcode is legacy and the Facebook generation has no idea what that could be ...
Yet my users are constantly complaining about my forum not supporting it well.
Feb 14, 2013 at 2:27 PM
jbrunken wrote:
zaratustra wrote:
You all do realize that BBcode is legacy and the Facebook generation has no idea what that could be ...
Yet my users are constantly complaining about my forum not supporting it well.
DITTO
Feb 14, 2013 at 2:32 PM
Just saying ....