What happened to "My Settings"

Aug 3, 2012 at 12:13 AM

A apologize if this has been addressed before, but I haven't seen any posts that address it.

What happened to the "My Settings" Tab?

I like that it uses the Core profile for a lot of things, but there are some very forum specific settings that are important too:

  • Sort Order
  • Items Per Page
  • Subscribe to Topics
  • Hide Signatures

etc...

Aug 3, 2012 at 2:02 AM
Create a child page under the user profile called forum settings. Drop an instance of Active Forums on the page. User settings should appear. Make sure you setup the page similar to the messages page. You only want the console module to show the page to the user.


Thanks,
Will


On Aug 2, 2012, at 4:13 PM, "jbrunken" <notifications@codeplex.com> wrote:

From: jbrunken

A apologize if this has been addressed before, but I haven't seen any posts that address it.

What happened to the "My Settings" Tab?

I like that it uses the Core profile for a lot of things, but there are some very forum specific settings that are important too:

  • Sort Order
  • Items Per Page
  • Subscribe to Topics
  • Hide Signatures

etc...

Aug 3, 2012 at 3:03 AM

Thanks will, that worked like a champ.   Love it!

I did run into one issue while I was configuring it.    In my main instance of the forum, I had HTML signatures turned on, but it was still stripping out the HTML.   I had to change that setting in the instance on the profile page for it to work properly.

I think I understand why it works that way, but I did find it a bit confusing.

This is certainly not a high priority thing, but it might be nice if the settings page filtered out the settings that don't make sense for a particular instance of the module.   Either that, or have the settings shared across instances.

Thanks again!

Sep 17, 2012 at 6:20 PM

Will I have to say - you made my month on this one.  I've been waiting and trying to figure out the whole deal with active forums and dnn forums.  I came into DNN just recently and the amount of information on the internet about this is vast and vague.  I'm glad to see this finally come out.

 

I have an issue and I'm hoping someone here can help me figure this out.  I was looking for a few options that I can't find anywhere.  I did as you instructed and added a child page to my profile called forum settings.  It appears but I'm only getting 1 of 2 results, either a copy of the forum already running, or a new forum.  I'm sure that I'm missing something somewhere but I can't figure it out to save my life.  I'm pretty sure it has to do with your comment "You only want the console module to show the page to the user" 

 

Can you elaborate on this a little please?

 

Also how on earth can I get the forum time to sync with either the portal time or user time?  I'm hoping that is in the forum settings and specific to user time zone.

 

Thanks

Sep 19, 2012 at 2:10 AM

So I guess I read this wrong.  Activity feed is the "profile page" my profile is a child of activity feed.  Creating a child of my profile didn't work.  Creating a child of activity feed did. 

Mar 11, 2013 at 8:05 AM
Glad I found this thread, was freaking out a bit ago thinking "how could signatures be no longer available"
Mar 12, 2013 at 4:16 AM
Hey Chris, if you got a quick second to reply to this I would appreciate it.

I'm attempting my first upgrade test from a DNN 5.0.3 to AF.

Per instructions it calls for AF 5.0. Is that accurate or any 5x of AF?

By the way I watched a few of your videos this weekent trying to learn my way around the new user directory and member directory module. Saved my butt big time. Got a large project dropped in my lap last minute for next weekend. Left me scrambling for answers. Thanks!
Mar 12, 2013 at 4:29 AM
I upgraded to 503 this weekend without trouble. Here are some of the steps I took

Conversion Steps (please test these for yourself before using in production)
Took the site offline, had a message on the production site that it was offline, I then accessed it using a different URL
Upgrade DNN to 7.0.4
Install AF 5.0.3
Add the Active Forums module to the Forums page (click the configure button)
Run conversion script. (be sure to set the source and target module ids
Configure AF Module Settings
Fix SortOrder on forums (edit table manually and change the values in the DB)
Change restricted forums to HIDDEN
Change permissions so that Registered Users can view/read
Go through permissions manually to make sure permissions are correct (the script permissions are kind of funky)
Configure AF URL Provider for URL Master (I haven't released this yet, will try to get a release out later this mont)
Install/Configure TapaTalk application
Move the DNNForum module to another admin restricted page

Add the What's New Module to a page and configure

Hopefully that helps
Mar 12, 2013 at 4:35 AM
You are the man. Quick too. Thanks
Mar 12, 2013 at 6:48 AM
Worked like a charm. There are definitely some strange security issues that happen after converting, but beats either not migrating or doing it by hand. Can't thank you enough Chris.

The real test will be the big one I'm planning to migrate in April.

Is there an easy way to find out how many threads/replies are on DNN forum? Permissions are all fudged as it is with poor housekeeping before I took over and poor leadership in the organization. I can't even imagine.

I need a SQL person and .net dev joined to my hip. Anyone looking for work? Must be able to cook/clean/babysit and know active directory :-)
Mar 12, 2013 at 6:52 AM
Shoot me an email, I can help ;)

As for number of threads/replies, yeah, if you have SQL access it is easy.
Jul 1, 2013 at 11:03 PM
I implemented this to allow my users to put in a signature, the problem I am running into now is that they can all change each other's forum settings. This might be a security bug?
Jul 1, 2013 at 11:07 PM
@mrwebslinger did you add the module to a new page, or the existing page?
Jul 1, 2013 at 11:13 PM
I added it to a new page under Activity Feed
Jul 1, 2013 at 11:44 PM
Sorry, major duh moment. The user that reported it had admin rights. I logged in as a non-admin and you can see the link but not do anything. Sorry for the false alarm.
Aug 7, 2013 at 9:02 AM
Does this method of Creating a Child Page called forum settings still work with 7.x? I cannot get it to display when editing the user profile.
Aug 9, 2013 at 10:17 PM
Hey guys... I'm football guy that knows a little coding configuration etc. I followed Will's steps but... no luck. So I figure there is more to it. Mentioned is a messages page and... I have no such page in my configuration.
Aug 12, 2013 at 2:45 AM
Dale it is definitely a little tricky and it depends on how you have your profile pages set up on dnn. For example:

There are 2 different sites both on DNN 7.0.6. One was a new install of DNN 7.0.6 and the other was upgraded from 5.6.7 to 7.0.6.

The fresh install already has the activity feed pages configured properly. In site settings you have user profile pointed to activity feed page, but the actual activity feed page has a few child pages; messages; friends (I honestly can't remember all of them right now). You need to create a new page called whatever you want. I use My Forum Settings. It needs to be a child page of whatever page you have your main profile page set to. The reason I say that is I have another site that was upgraded. Basically the User Profile page has messages, and some other stuff all on 1 page. I never switched it all over. Once again you still need to create a child page of that one for forum settings.

Regardless how you are set up, it has to be on a child page of user profile (I haven't tested the 1 page setup to see if that works too - all on the same page) but drop another instance of active forums on that page. Configure it via module settings and it should work just fine.

This sounds a lot easier to explain in my head. Does that even make sense at all? If you want, activeforums.org is configured as a fresh install of DNN 7 with multiple profile pages, using the console module as the profile menu. If you want to create a login you can see some of it there.

Hope this helps a little.
Aug 12, 2013 at 5:33 AM
I have an upgrade of 5.x.

I created a page called forum settings and it is a child page of my User Profile page defined in Admin/Site Settings/Advanced Settings/Page Management/User Profile Page

When I dropped an instance of Active Forums on that page it did show just the user console for active forums. However, when I Go to the user profile page to make changes to the profile and hopefully edit the active forum settings nothing is generated to show Active Forums settings

I tried dropping an instance on the User Profile Page but that doesn't work at all.

So your last comment is to configure via module settings. I made a change in Module Setting of the Module Title to My Settings. What other settings should I make?

I guess if I understood how the parent page enumerates the information from the child page it would make this easier, but I don't.
Aug 18, 2013 at 10:11 PM
I've resolved this issue at least...
Oct 16, 2014 at 10:50 AM
Edited Oct 16, 2014 at 11:02 AM
Hi There,

Looking for some help on this please. We have just upgraded from an old version of AF to the latest.

All our avatars are missing, but so is My Settings.

I have added a page called "Forum Settings" as a child to "User Profile"

When I load up the forums, "My Settings" doesn't show in the toolbar. Loading the page manually does show the settings however.

Any assistance please?